Vulnerability development tools

Tools

Halcyon IDE (development interface for Nmap NSE scripts)

exploit development, penetration testing, security awareness

Halcyon IDE provides an interface to develop Nmap scripts (NSE). These scripts can be used to extend the functionality of Nmap and perform more advanced scans on applications and infrastructures. By using an IDE, the development of NSE scripts can be simplified.

Pocsuite (vulnerability testing and development framework)

vulnerability development, vulnerability testing

Pocsuite is a remote vulnerability testing and development framework. It can be used by penetration testers and vulnerability researchers.

Missing a favorite tool in this list? Share a tool suggestion and we will review it.